[FEATURE ADDED IN v1.67] Bug @ character close citrix c...

Get help with problems with mRemoteNG.

[FEATURE ADDED IN v1.67] Bug @ character close citrix c...

Postby Nero » Tue Oct 19, 2010 1:14 am

Hi,
When I use the @ simbol during a connection (for exemple for send a mail), all the citrix tabs close...
This problem affect only ICA connections.
When I use the character @ in RDP connections, it work with no problem...
Anyone have the same problem?
I think it's a bug.

Have a nice day
Nero
Nero
 
Posts: 14
Joined: Thu Jun 10, 2010 6:10 am

[FEATURE ADDED IN v1.67] Bug @ character close citrix c...

Sponsor
 

Re: Bug @ character close citrix connection

Postby Cetan » Tue Nov 02, 2010 6:51 am

That is, to say the least, a bit strange...

On my computer (Windows XP, using ICA in full screen mode) I don't have this problem.
What settings do you use?
Cetan
 
Posts: 9
Joined: Mon Jan 18, 2010 10:52 pm

Re: Bug @ character close citrix connection

Postby Nero » Wed Nov 03, 2010 9:04 am

Hi! Thanks for the answer.

I use mRemoteNG 1.63.
For citrix connection I use the default option.
Ip: server ip
Encryption: Basic
Resolution: Fit to Panel

So if you press "Alt-gr + @ symbol", yours connections are still open?
All my ICA citrix close... but not RDP.

Why?
The problem is citrix?

Have a nice evening.
Nero
Nero
 
Posts: 14
Joined: Thu Jun 10, 2010 6:10 am

Re: Bug @ character close citrix connection

Postby Cetan » Thu Nov 04, 2010 12:10 am

Nope ... nothing happens with my Citrix connection.
Are you using the VS international keyboard layout? (Why the combination: Alt-gr + @ ?)

It might be a windows short-cut combination on your computer, causing the behavior?
Cetan
 
Posts: 9
Joined: Mon Jan 18, 2010 10:52 pm

Re: Bug @ character close citrix connection

Postby Nero » Thu Nov 04, 2010 5:28 am

Thanks Cetan,
I have the italian keyboard. For @ symbol on italian keyboard we use AltGr+@.
It's strange because in Windows no short-cut combination are used. I have tried on another PC and the problem is the same.
I don't have a english keyboard for test it...
If I use the ascii code (Alt + 64) the symbol @ work in citrix connection.... but the solution isn't so nice....

Thanks for the moment
Nero
Nero
 
Posts: 14
Joined: Thu Jun 10, 2010 6:10 am

Re: Bug @ character close citrix connection

Postby Nero » Thu Nov 04, 2010 5:44 am

I have tried setting EN language on Windows, and the problem is solved!
Is there a bug for the italian keyboard standard?
On the italian keyboard the @ symbol is on the right of "L" symbol. For use it, it's necessary press the AltGr.

On english keyboard there isn't problem.

What can I do?
Nero
Nero
 
Posts: 14
Joined: Thu Jun 10, 2010 6:10 am

Re: Bug @ character close citrix connection

Postby Nero » Mon Nov 08, 2010 8:22 am

Cetan,
can you try to press "F1" button on a citrix connection?
All citrix connections close....
The some problem of "@" button on the italian keyboard....

Can you try with your internation keyboard?

Bye
Nero
Nero
 
Posts: 14
Joined: Thu Jun 10, 2010 6:10 am

Re: Bug @ character close citrix connection

Postby Cetan » Mon Nov 08, 2010 9:57 pm

I tried that: it does close indeed when I press F1 (and no shell is active)!

However, in case a shell is on top it does not close but it prints
eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
to the active shell prompt.

I can imagine there might be some special character send to the citrix connection when pressing F1 (or @ in case of Italian keyboards).

It would be interesting to hear from one of the designers if they have an explanation.
I'll check if I can find anything too...
Cetan
 
Posts: 9
Joined: Mon Jan 18, 2010 10:52 pm

Re: Bug @ character close citrix connection

Postby Nero » Fri May 06, 2011 8:06 am

Hi,
is it possible correct this problem?
I have tried the new version 1.66 but the problem is the same...

Thanks!
Have a nice week-end
Nero
 
Posts: 14
Joined: Thu Jun 10, 2010 6:10 am

Re: Bug @ character close citrix connection

Postby thrilleratplay » Mon May 09, 2011 3:59 pm

I am still in the middle of centralizing all of the issues and feature requests. I did not get to this one yet. This is an odd issue but I think I found the cause:
http://support.citrix.com/proddocs/index.jsp?topic=/ica-settings/ica-settings-hotkey10shift.html
This has been something users have been complaining about for 5 years or so. I believe just committed a fix that disables the Citrix hotkeys. However I do not have an international keyboard nor a Citrix server to test this. I hope to have a release candidate in a day or so. Would you mind testing this? If it does not fix it, it will likely be awhile before we can dig deep enough to find the cause.
User avatar
thrilleratplay
 
Posts: 91
Joined: Wed Jan 12, 2011 9:21 pm

Next

Return to Support

Who is online

Users browsing this forum: No registered users and 3 guests