ICA connections

Get help with problems with mRemoteNG.

ICA connections

Postby aehimself » Tue Jul 26, 2016 12:12 am

Since the initial release of mRemote I was struggling setting up an ICA connection. I was extremely happy to see that the project of mRemoteNG is not abandoned, but my issue still exists.
Can someone please guide me, in how ICA connections should work / be set up?

First things first: Windows 10 x64, Citrix Receiver 4.4.0.8014 is installed. Tools -> Components Check confirms that "All ICA components were found and seem to be registered properly. Citrix ICA Client Control Version 2.10".
I know that I must try with published desktops, not applications, which is fine. If I doubleclick on an .ICA file, it launches and connects to a server properly. If I edit open the file with Notepad and try to connect to the host IP with mRemoteNG, an empty panel appears, saying "Invalid parameter". Log shows:

2016-07-26 10:09:59,974 [1] INFO - Protocol Event Connected
2016-07-26 10:09:59,974 [1] INFO - Connection to "w.x.y.z" via "ICA" established by user "myuser" (Description: ""; User Field: "")
2016-07-26 10:10:00,350 [1] INFO - Protocol Event ErrorOccured
2016-07-26 10:10:01,517 [25] INFO - Connection Event Closed
2016-07-26 10:10:01,517 [25] INFO - Connection to w.x.y.z via ICA closed by user myuser.


Any ideas? It would be awesome to be able to import all Citrix connections to mRemoteNG at last!
aehimself
 
Posts: 4
Joined: Wed May 22, 2013 7:19 am

ICA connections

Sponsor
 

Re: ICA connections

Postby sharctao » Wed Jul 27, 2016 8:07 pm

I have the same question. will watch any updates about this.
sharctao
 
Posts: 2
Joined: Sun Jun 26, 2016 2:53 pm

Re: ICA connections

Postby aehimself » Wed Oct 19, 2016 3:51 am

Bump... Did anyone manage to connect to a Citrix session with mRemoteNG until now? :|
aehimself
 
Posts: 4
Joined: Wed May 22, 2013 7:19 am


Return to Support

Who is online

Users browsing this forum: No registered users and 5 guests