[FEATURE ADDED IN v1.62] Changes from 1.50

Get help with problems with mRemoteNG.

[FEATURE ADDED IN v1.62] Changes from 1.50

Postby earlyEd » Wed Jan 13, 2010 11:52 am

Hi -
Glad someone is taking on the project. I got the source last year from Felix but never found time to get into the code.
I am using the old version extensively for work, but will switch to mRemoteNG 1.60 and report any issues I find.

One issue I'm interested in getting resolved is that the inheritance buttons disappear after using mRemote for awhile.
Haven't found steps to reproduce it yet, but it occurred on my old Windows XP box and my current Windows 7 install.

Also, do you have a list of changes you've made from the 1.50 version? Or should I just glean those from Github comments?

Cheers!
earlyEd
 
Posts: 5
Joined: Wed Jan 13, 2010 11:44 am

[FEATURE ADDED IN v1.62] Changes from 1.50

Sponsor
 

Re: Changes from 1.50

Postby rmcardle » Wed Jan 13, 2010 12:31 pm

Here's a link to the change log:

http://update.mremoteng.org/changes-1.60.txt

Not much has changed for this version. I mainly wanted to get the release process worked out and get something out there for feedback.

I had never used the inheritance feature. Trying it now, it does seem to be rather buggy. I'll add that to my list for the next release. Thanks for bringing it to my attention.
User avatar
rmcardle
Site Admin
 
Posts: 459
Joined: Thu Jan 07, 2010 3:40 pm

Re: Changes from 1.50

Postby earlyEd » Wed Jan 13, 2010 1:34 pm

I didn't use the inheritance feature until several months after a I started to use mRemote - but now that I manage many servers in various domains I see the value.

Also, I just noticed this today, but there appears to be a bug when using the copy function in an RDP session. If you press CTRL-C or use the mouse and select the context menu "Copy", the cpu usage of the mRemoteNG process goes to 50%. I haven't experimented much, but to make it go down to normal, I change focus to my local OS and hit the CTRL, WIN, and ALT key a few times each and then copy some text (also locally). CPU usage goes down after that.

I'm running Windows 7 Pro 32-bit with all the latest updates.
earlyEd
 
Posts: 5
Joined: Wed Jan 13, 2010 11:44 am

Re: Changes from 1.50

Postby rmcardle » Wed Jan 13, 2010 5:00 pm

I'm looking at the code for the inheritance buttons and I don't see any glaring problems. When you say they are disappearing, are they grayed out when they shouldn't be, or are they completely missing? Is it just the icon that is missing or the whole button? If you hover your mouse over the area where it should be, does the button border show up? How about the tooltip?

As far as the copy issue, I can't seem to reproduce it. Do you have redirect key combinations enabled? What are you copying? Just a small amount of text, or something larger?
User avatar
rmcardle
Site Admin
 
Posts: 459
Joined: Thu Jan 07, 2010 3:40 pm

Re: Changes from 1.50

Postby earlyEd » Thu Jan 14, 2010 9:50 am

I've attached a screenshot of what it looks like when the buttons disappear.
1) They just go away and don't come back.
2) I've tried to close and reopen the config panel and select other hosts, etc, but nothing works except restarting the program.
3) I seem to always notice it first thing in the morning after I unlock my computer - so the mremoteng process will have been running overnight.
4) Another possible factor is that I'll sometimes RDP into the computer running mRemoteNG. I haven't noticed if they're missing then, but next time I do this I'll check.
5) Lastly, another thing to note is that I have a dual monitor setup. I haven't run mremote on a single monitor so I don't know if the behavior is the same.

Copy Issue:
1) CPU usage goes and stays up regardless of what I am copying - if I copy a file or copy some text via menu or key combination the result is the same.
2) Further testing showed that my original resolution of pressing the ALT,CTRL, and WIN keys is uneeded - if I just copy something (text or file) on my local OS the CPU usage goes back down.
3) I did another test to see what happens when I copy from a standalone mstsc.exe connection. CPU usage typically does not change, but once or twice I saw a momentary spike, but it immediately went back to normal.
4) I do have redirect keys enabled for all my RDP sessions.
5) I have a feeling this is tied to the shared RDP clipboard functionality. In my usage of mstsc, I have frequently seen the shared clipboard function stop working for existing and new mstsc connections, so I don't think it's perfect to begin with...

I downloaded the 1.60 source and will try running that in debug mode to see if I can pinpoint the source of any of these issues. Is there any way to track where in code the app is using the CPU cycles?
Attachments
mremoteng-missingInheritance.jpg
Screenshot of missing inheritance button
mremoteng-missingInheritance.jpg (8.14 KiB) Viewed 13060 times
earlyEd
 
Posts: 5
Joined: Wed Jan 13, 2010 11:44 am

Re: Changes from 1.50

Postby rmcardle » Mon Jan 18, 2010 11:16 pm

I think I found the problem with the buttons disappearing. I think they were getting garbage collected by the .NET Framework. This should be fixed in 1.62.

For the clipboard problem, are seeing this on Windows 7? What OS is the remote computer running? Does this happen with any remote computer you connect to, or only certain ones? Does the CPU usage increase on the remote computer also? If so, what is using the CPU on the remote computer, RDPCLIP.EXE or something else?
User avatar
rmcardle
Site Admin
 
Posts: 459
Joined: Thu Jan 07, 2010 3:40 pm

Re: Changes from 1.50

Postby earlyEd » Mon Jan 25, 2010 9:47 am

Great, thanks! I'm testing 1.62 now to see if the inheritance bug is fixed.

As for the clipboard issue, I can't seem to consistently get it to happen - I'll keep checking and let you know if I can get some replication steps and what processes are going wild.
earlyEd
 
Posts: 5
Joined: Wed Jan 13, 2010 11:44 am

Re: [FEATURE ADDED IN v1.62] Changes from 1.50

Postby pm010537 » Sun Jul 22, 2012 10:59 pm

I am running version 1.69 and I am still seeing exact same problem. I am running mRemoteNG on windows 7. It works fine but after keeping it running for a while, I start running into this problem of inheritance button. It will be nice to fix this problem.
pm010537
 
Posts: 2
Joined: Sun Jul 22, 2012 10:54 pm


Return to Support

Who is online

Users browsing this forum: Bing [Bot] and 5 guests