Help with Building

Messages and questions from developers working on mRemoteNG.

Help with Building

Postby baluvee » Sat Nov 19, 2011 6:50 pm

Hi
I have VS 2008, downloaded source. copied dll to references folder. I am getting error while building


Error 59 'RemoteDesktop' is ambiguous in the namespace 'VncSharp'.
Error 62 'VncClient' is ambiguous in the namespace 'VncSharp'.
Error 64 Type 'EOLWTSCOM.WTSCOM' is not defined.

any help is appreciated
baluvee
 
Posts: 3
Joined: Sat Nov 19, 2011 5:22 pm

Help with Building

Sponsor
 

Re: Help with Building

Postby Reginald » Tue Nov 22, 2011 6:17 pm

Hello,

I was recently able to build the "release/1.69" branch from github using VS 2010 SP1. I didn't hit the first two errors, but the third was solved by running "regsvr32 eolwtscom.dll" and making a COM reference to the library. I tried just making a direct file-based reference, but it kept complaining that it wasn't a valid DLL.

Hope that helps!
Reginald
 
Posts: 8
Joined: Tue Oct 18, 2011 5:44 am

Re: Help with Building

Postby baluvee » Fri Dec 02, 2011 1:24 pm

thanks man. But I got everything sorted out. I am able to build the project in Win7 64 bit VS 2010
baluvee
 
Posts: 3
Joined: Sat Nov 19, 2011 5:22 pm

Re: Help with Building

Postby rmcardle » Sun Dec 04, 2011 8:56 pm

Would either of you like to help out with development? We need all the help we can get. Especially with coordination and project management. If you are interested, let me know and I can give you access to our Present.ly feeds where we discuss development.
User avatar
rmcardle
Site Admin
 
Posts: 459
Joined: Thu Jan 07, 2010 3:40 pm

Re: Help with Building

Postby baluvee » Tue Dec 27, 2011 11:11 am

I will be happy to give back something to this community. I need to go through the code first. so let me go through the code first and get back to you
baluvee
 
Posts: 3
Joined: Sat Nov 19, 2011 5:22 pm

Re: Help with Building

Postby rmcardle » Tue Dec 27, 2011 1:19 pm

Excellent. Let me know if you need help with anything. If you are interested, I can invite you to our Present.ly feed where we collaborate on development.
User avatar
rmcardle
Site Admin
 
Posts: 459
Joined: Thu Jan 07, 2010 3:40 pm

Re: Help with Building

Postby Predatorian » Tue Nov 12, 2013 8:40 am

I'm not a VB.Net programmer at all, but learning, and have never used the Visual Studio suite for programming. I do a little C++ and mainly Ruby programming. I am interested however in helping with this. How do I go about loading this project from the GitHub page into Visual Studio after I cloned it to my system?

--EDIT 2014-05-18 --

I have figured out the build process a little bit, but I'm on Linux, using MONO, so no Visual Studio. Is there any libraries I'm missing, or is there a process to build it by hand if I don't have Visual Studio?
Predatorian
 
Posts: 6
Joined: Tue Sep 10, 2013 7:37 am

Re: Help with Building

Postby KenNashua » Mon Mar 09, 2015 11:52 am

I just decided to try to do a local build and am running into the follow errors:

Error 6 Type 'AxICAClient' is not defined. \git\mRemoteNG\mRemoteV1\Connection\Connection.Protocol.ICA.vb 12 28 mRemoteV1
Error 8 'WFICALib' is not declared. It may be inaccessible due to its protection level. \git\mRemoteNG\mRemoteV1\Connection\Connection.Protocol.ICA.vb 146 43 mRemoteV1
Error 15 Type 'AxWFICALib.AxICAClient' is not defined. \git\mRemoteNG\mRemoteV1\UI\UI.Window.ComponentsCheck.vb 574 28 mRemoteV1
Error 25 The referenced assembly "\git\mRemoteNG\mRemoteV1\bin\Release Portable\mRemoteNG.exe" was not found. If this assembly is produced by another one of your projects, please make sure to build that project before building this one. TestProject
Error 35 Type 'ExternalTool' is not defined. \git\mRemoteNG\TestProject\ExternalToolTest.vb 52 33 TestProject
Error 36 Type 'Info' is not defined. \mRemoteNG\TestProject\ExternalToolTest.vb 55 43 TestProject

I didn't see any build instructions other than BUILD.CMD. This was built with fresh git clone from the develop branch and VS 2010.
KenNashua
 
Posts: 5
Joined: Sun Mar 10, 2013 7:45 am

Re: Help with Building

Postby rmcardle » Tue Mar 10, 2015 8:52 am

KenNashua wrote:I just decided to try to do a local build and am running into the follow errors:

Error 6 Type 'AxICAClient' is not defined. \git\mRemoteNG\mRemoteV1\Connection\Connection.Protocol.ICA.vb 12 28 mRemoteV1
Error 8 'WFICALib' is not declared. It may be inaccessible due to its protection level. \git\mRemoteNG\mRemoteV1\Connection\Connection.Protocol.ICA.vb 146 43 mRemoteV1
Error 15 Type 'AxWFICALib.AxICAClient' is not defined. \git\mRemoteNG\mRemoteV1\UI\UI.Window.ComponentsCheck.vb 574 28 mRemoteV1

You need to install Citrix Online Plug-In – Web.
User avatar
rmcardle
Site Admin
 
Posts: 459
Joined: Thu Jan 07, 2010 3:40 pm

Re: Help with Building

Postby KenNashua » Thu Mar 12, 2015 10:43 am

Thanks! Did I miss something obvious in a readme somewhere?
KenNashua
 
Posts: 5
Joined: Sun Mar 10, 2013 7:45 am

Next

Return to Developers

Who is online

Users browsing this forum: No registered users and 1 guest